question

Neil Hall avatar image
Neil Hall asked ·

Normal Map problems from Substance Painter to Maya Arnold 5

I've got progressively frustrated, today, trying to solve what is going on with my render.

I've exported all of my textures from Substance Painter using the Arnold 5 Preset. I've made all of the maps RAW. I've set the Bump to Tangent Normal and swapped the R & G channels. I've used Alpha is Luminance (though, I'm just clutching at straws with that).

The worst thing I can't figure out (even though, its all broken) is what is causing the complete blackness in the render? There is one overhead area light shining straight down. All the face normals are pointing outwards. It's definitely the normal map that is causing the problem. Reverting back to Bump Maps solves the 'black' issue but breaks the normals' "look", obviously. Switching to Object Normals fixes the 'black' problem but my normal-maps don't render any more. Grrrrrr!

Any ideas would be appreciated before I simply turn all of the bump maps off. :-(

Thanks.

normal mapsubstance painter
1 comment
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

mehrdad farzi avatar image
mehrdad farzi answered ·

@Neil Hall i'm not sure what is causing your problem but try using aiNormalMap instead of Maya bump 2d.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Neil Hall avatar image
Neil Hall answered ·

Thanks guys. It was a combination of things. I swear I had the correct settings earlier on, but probably not every piece. So, I got confused with what was right and what was wrong. :-/ All sorted. It was just me being a bit of a pillock.

Thanks again to everyone who looked at it and offered advice.

Neil

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Neil Hall avatar image
Neil Hall answered ·

Yeah, it just seems to be certain angles. It's definitely based on something to do with the polys' angle to the camera. Thanks for looking at it. I really appreciate it. I can't get rid of it. It happened on a previous file, using Substance, too, and that was a fixed mesh-object that wasn't mirrored. Again, exported from 3ds Max.

https://youtu.be/lztz8cQpwb4

Thanks again,

Neil

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Lee Griggs avatar image
Lee Griggs answered ·

Left (sRGB). Right (RAW)


bike3.jpg (63.7 KiB)
Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Lee Griggs avatar image
Lee Griggs answered ·

If you set it to RAW it works. More information here.


normal-raw-bike.jpg (49.4 KiB)
Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Neil Hall avatar image
Neil Hall answered ·

The meshes causing the problem seem to be the ones where I've modelled one side and then mirrored it and then joined the two pieces together. All done with the Mirror tool in 3ds Max with Join Seams active. Doesn't explain how the black artefact can travel across the middle of the mesh and not split down the middle.

I'll try an export in OBJ and see if that makes any difference.

Thanks.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Neil Hall avatar image
Neil Hall answered ·

Thanks. I deleted all of my TX files, in case they weren't refreshing and let them all be rebuilt. Made sure everything was RAW, like you say... which I'm fairly sure they were in my file, too. The first and second image are a small change in camera angle. I still get this: -


capture03.png (399.5 KiB)
Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Neil Hall avatar image
Neil Hall answered ·

Using aiNormalMap seems to have solved the issue of the blackness appearing, but now there's a pretty strong seam where the two UV shells meet (although, I've seen this using 2dBump, too). You can see it to the left of "Delphine" and moving vertically until it branches off.


capture.png (814.6 KiB)
Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Neil Hall avatar image
Neil Hall answered ·

Here's the file with just the textures for the main body and the seat.

The bike was originally modeled and animated in 3ds Max, exported as a FBX and imported into Maya. I used a lot of mirroring on the bike, but checked that all the normals were pointing outwards. I don't know a huge amount of modeling in Maya. A non-animated version of the bike (without the locators) was used to texture the model in Substance Painter.

Lastly, I've never tried Sharing a file on Google before. Hope the link works.

Thanks,

Neil

https://drive.google.com/file/d/1HT32VPTKDwYlFCNBnBPbRmTMDsGiZP4q/view?usp=sharing

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Lee Griggs avatar image
Lee Griggs answered ·

Can you upload the map/geo in question?

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.