question

nimrod zaguri avatar image
nimrod zaguri asked ·

AiStandardHair can't read texture information (Xgen)

Hi,

I've been dabbing in grooming fur on my raccoon for some time now,

I've tested aiStandardHair numerous times by now and they all seem to work properly when I simply plug in a color map.

Suddenly this is no longer the issue, for reasons I can't understand texture maps, and even ai-noise seem to have no effect on the general color anymore.

I'm attaching a quick test image on a blank file with nothing but the model and the simplest fur setup

- Deleted prefs a couple of times.

- Tried using aiImage instead of texture

- Tried differend model

- Tried different texture

- Tried making new UVs (Textures did work on that model as I can recall

- Color values by sliders work*

- Ramp color values does work

- Deleted the whole Xgen files a couple of times (untill I messed up my whole description unfortunately)

Any suggestions will be helpful, I'm pretty desperate by now

Cheers,

Nimrod

mtoaarnold5hair
capture.png (546.0 KiB)
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

nimrod zaguri avatar image
nimrod zaguri answered ·

I see what you mean now about the new interactive groom splines, seems much easier to work with that I've been having all of that headache or nothing. I figured the interactive groom splines are the old system...

BTW The tutorial worked but created some weird changes of color values when converting to ptex

Thanks for all the help. mighty awesome of you :D

Nimrod

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

nimrod zaguri avatar image
nimrod zaguri answered ·

I've made another test, This time with a simple ball, same setup with the texture just with a brighter one so I can pinpoint what color goes into the Xgen

- The ball has it's default UVs but apparently each hair calculates the texture on its own uv,

- Also, when I switch from ribbon to thick I get a completely different result which colors only the bottom of every hair with the yellow from the texture

Ribbon:

Thick:


capture2.png (1.8 MiB)
capture3.png (833.9 KiB)
Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

nimrod zaguri avatar image
nimrod zaguri answered ·

I've been using the new interactive groom, thing is that it worked on my first tests and somewhere along the way just stopped without giving any signs to what actually caused it...

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

I think this a UV problem. The original Xgen, which you are using, didn't have UVs for hairs (the new interactive groom splines do).

So you have to use user data, as shown in this tutorial:
https://docs.arnoldrenderer.com/x/aQ1kAg

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

That looks ok.

In the image node, turn off "ignore missing textures"
Right now it is on, so if a texture is not found, the color grey is used, which looks a lot like your screenshot.

And also get an Arnold log to check what's happening...

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

nimrod zaguri avatar image
nimrod zaguri answered ·

Thanks for the quick response! I really appreciate it.

racoon-fur-test-v01.ass


Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

Export an ass file. Let's see what you're getting.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.