question

Huang Yaofeng avatar image
Huang Yaofeng asked ·

aiVolume (Step Size?) render artefact with aiStandard Volume in Maya

I use ai Volume to render a smoke of Houdini with VDB, but it appears artefact

I change step size of AiVolume, and the artefact change, so I assume that's the problem, but even I use 0.001 step size, I can still see the artefact, how can I fix this?...

Thanks in advance

StepSize 0.1

StepSize 100

Update:

In the scene there are two AiVolume, but we can't see the other AiVolume through camera.

I really don't think the quality is the problem, it looks like this when I render without the other AiVolume, (the black part inside the smoke is the shadow of environment)

With Environment

Without Environment

So maybe there is some parameters I have to set to avoid the artefect influenced by the shadow of the other AiVolume?

rendervdb
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Girijashankar Senapati avatar image
Girijashankar Senapati answered ·

Can u try increasing the volume resolution(quality) and them export from houdini? That might help.

1 comment Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

The reason is shadow of another VDB's Volume, after I deleted it, artefact disappears, even with lower quality of VDB...

0 Likes 0 · ·
Lee Griggs avatar image
Lee Griggs answered ·

Are you using Volume Displacement? Do you have any other shaders connected to the Standard Volume?

2 comments Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

No, I just use Standard Volume, displacement is 0,0,0; no Volume Dispacement involved

The reason is shadow of another VDB's Volume, maybe I miss some parameter to set in Lighting or Render Setting?

0 Likes 0 · ·

I have this issue from time to time (especially when using displacement). Maybe try Girijashankars advice.

0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.