question

Adam Phillips avatar image
Adam Phillips asked ·

Shaders not available?? houdini installation 17.5

I've installed a trial of arnold for houdini 17.5 and set the license file so that the arnold shelf is available and there are no watermarks.The lights work in the view port but once rendering, the lights do not seem to be working with only a default headlight having any effect and also there aren/t any arnold shaders available in my tab menu or the tree view in the materials pallette. It seems like half an installation - where did i go wrong?

houdini
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Greg Hughes avatar image
Greg Hughes answered ·

@Adam Phillips: Can you explain how you updated your env file? I have the same problem.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Adam Phillips avatar image
Adam Phillips answered ·

Hi @Stephen Blair, Solved. I found to add Arnold properties to the object. I'm transferring over from a Mantra setup which was fine but ate ram like a hungry beast. would you mind shedding light on why Arnold doesn't seem to be rendering with an object with UDIMs? i'm using %(UDIM)d in the file name. Arold doesn;t seem to be rendering at all until I disconnect the UDIM texture.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Adam Phillips avatar image
Adam Phillips answered ·

Thanks stephen! It was the env file that needed the path. Do you mind if I ask one more question? I'm trying to setup displacement - the tutorial is fairly old and already there are differences. I seem tto be absent a bump in put on my out shader node, and also when i connect my displacement map tot he displacement slot it does nothing. I tried - in a maya imitation to to this via a bump 3d node also but still no luck. On the arnold documentation it says that there should be subdivision controld on the geometry node but I also cant see this. I think i've successfully strecthed 5 mins of work over 3 hours hehehe. slowly going crazy

1 comment Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

@Adam Phillips do you have UVs on the shape?

0 Likes 0 · ·
Stephen Blair avatar image
Stephen Blair answered ·

Is anything logged by HtoA at startup (in the Houdini Console) ?

What's your houdini.env look like?

Check the environment in Help > About Houdini > Show Details

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.