question

Cherylynn Lima avatar image
Cherylynn Lima asked ·

why wont' arnold work with xgen in maya 2019?

When i try to render with xgen, the arnold renderer does not show up. It shows up in 2018 but not 2019.

renderarnold
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

The only time I ever see # Error: line 1: [xgen] Could not initialize the Patch renderer # is if I haven't saved the scene yet.

And there should be some other messages in the script history.


1 comment Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Yepp, saved the scene and all is fine. I can't believe I missed that. Thank you so much.

0 Likes 0 · ·
Cherylynn Lima avatar image
Cherylynn Lima answered ·

I figured out the solution was to drag out my preferences folder in documents and let maya recreate it on opening

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Joel Nathanael avatar image
Joel Nathanael answered ·

I too am having the same problem when rendering an xgen description/collection. Specifically, when I run IPR or a full render the collection does not show up. Additionally, the collection intermittently displays in the view window. I've uninstalled and reinstalled (2019.2) twice to no avail. I've also tried what the OP suggested with no change. This is consistent on both of my machines, Mac Pro Late 2013, Mac Book Pro 13in 2017 all running MacOS 10.14.6.



Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Lee Griggs avatar image
Lee Griggs answered ·

Could you provide some more details about the scene, please? When you say the Arnold renderer does not show up, do you mean it does not render in the Arnold Renderview window?

Could upload a log file or even a simplified scene, please?

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.