question

Shawn Marshall avatar image
Shawn Marshall asked ·

Odd blur of bitmap through glass object

In creating a scene of a car on a highway I encountered an artifact I can't pin down in which the bitmap I've applied to the highway texture receives an odd blur.

In this render of a simplified scene I have a strip of transparent polygons running across the frame. No roughness, Thin-walled geometry, IOR 1.59. Note that the cube isn't being blurred, just the highway texture near the top edge of the glass strip:


In this render of the same scene I've replaced the highway bitmap with procedural stripes made with the Checkerboard texture. No blurring is visible here:

Am I missing a checkbox or setting somewhere? Here's the R20 scene file:

https://www.dropbox.com/s/s3e5f1j2oplqooa/WeirdGlassBlur.zip?dl=0

Thanks!

Shawn Marshall

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Thiago Ize avatar image
Thiago Ize answered ·

This is very likely due to the texture differentials being used.

I don't have c4d, so can't try out your scene, but one quick thing you can try on your end is to toggle the global options texture_conservative_lookups from true to false. While that will result in more texture memory usage, it might fix this. If it doesn't, then it's probably a bug in Arnold we need to fix.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Shawn Marshall avatar image
Shawn Marshall answered ·

Hi Thiago:

Thanks for the reply. I don't know how you toggle the feature you've described to FALSE. I'm guessing it's a Terminal thing, and I generally avoid touching the Terminal. I can't find step-by-step instructions to do what you've described.

I've found a workaround that will suffice for now. If I use the native Arnold Image texture node (I'd been using the C4D bitmap node to bring in my highway image) and set its Mip-mapping bias to -8 the blur will be reduced to an acceptable level. I'll have to animate that value back down to 0 when I fly my camera out of the car to an omniscient perspective.

Cheers.

Shawn

6 comments Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

In the Render Settings, Diagnostics tab.

Put this in the User Options:

texture_conservative_lookups  off

1 Like 1 · ·

That did the trick, thanks so much! I did do a Google search for "global options texture_conservative_lookups arnold", but it didn't point me to that Diagnostics tab.

Cheers!

Shawn

0 Likes 0 · ·

Glad that worked! If you're happy with the solution, can you please mark this question answered?

0 Likes 0 · ·
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.