question

Marcus Jungerstam avatar image
Marcus Jungerstam asked ·

"// Warning: [mtoa] [translator polymesh] ...." Bug?

I get alot of "// Warning: [mtoa] [translator polymesh] ShadingGroup aiUtility1SG MPlug not found"

When rendering with render layer overides now days. Even when not having renderlayers I get this issue from time to time.


So alot of black, pink or emty renders like the image I attached. The scens works fine when rebooting maya but after 10-30 min the issue is back and then only a reboot fixes it for me. some time exporting all shadinggroups works as a fix but mostly not.


Does anyone have a fix for this? Or is it a bug?



warning.jpg (45.1 KiB)
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Marcus Jungerstam avatar image
Marcus Jungerstam answered ·

It seams to be shader overrides that makes my scene to brake. It works to assign the shader to faces instead of the whole mesh.


I cant share the scenes from this project I'm afraid :(


But there are more people in the studio having the same issue with other scenes

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

Looks like a bug with render layers. MtoA tries to process the nodes and connections, and somewhere a connection leads nowhere.

I couldn't repro that situation manually. Could you upload a simple test scene that shows the problem?

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.