question

Matt Mlodzienski avatar image
Matt Mlodzienski asked ·

aiColorJitter for standins?

I have trees that I'd like to jitter the color of the leaves on, and then instance them as standins. What's the best way to do it so the standins aren't all identical? Or is there no way?

shadersmaterialscolor
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

You can use the procedural settings in aiColorJitter

but you'll have to disable the procedural cache in the scene

Paste this in Render Settings > Diagnostics > User Options

enable_procedural_cache off
Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Matt Mlodzienski avatar image
Matt Mlodzienski answered ·

@Stephen Blair thanks for the response! That fixed it!

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Christophe Jeudy avatar image
Christophe Jeudy answered ·

Isn't the render time tremendously longer when you disable the procedural cache in the scene?

Trying to introduce jitter on my standin trees ..

1 comment Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Yeah, there's definitely a cost to disabling the procedural cache

0 Likes 0 · ·
Stephen Blair avatar image
Stephen Blair answered ·

Yup, still works.


jitter-procedural.jpg (171.1 KiB)
Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Chris Meyers avatar image
Chris Meyers answered ·

@Stephen Blair Is this still valid for Arnold 5.1.0.1, MtoA 3.0.0.2?

I had it working in an older version but I can't seem to get it to work now.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.