question

Changyoon Chung avatar image
Changyoon Chung asked ·

Arnold and steam version of Houdini on macOS compatibility issue

Ok, so I have asked this related question last time as well.


I was told that Arnold to Houdini works perfectly fine on macOS, and I've tried everything, all the builds available from 17.0 to 18.0 and all corresponding Arnold versions up to 5.2.1. They all don't work displaying same issue. I thought this could be my personal machine issue, so I tried this on my other MacBook Pro and it displays the same issue. I did a bug report to SideFX and they told me to hand it over to Solidangle, and when I asked here nobody could resolve this issue so I think it's not possible to use it.


Command Exit Code: 250

00:00:00 57MB | [hick] Lowered process priority to 19
00:00:00 57MB | [hick] Received: AA: 3 3
00:00:00 57MB | [hick] Received: begin
00:00:00 57MB | [hick] Batch mode
00:00:00 57MB | log started Mon May 18 10:23:08 2020
00:00:00 57MB | Arnold 6.0.2.1 [088e32fd] darwin clang-5.0.2 oiio-2.1.4 osl-1.11.0 vdb-4.0.0 clm-1.1.2.132 rlm-12.4.2 2020/03/06 10:20:27
00:00:00 57MB | running on CHANGYOONs-MacBook-Pro.local, pid=6658
00:00:00 57MB | 1 x Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz (6 cores, 12 logical) with 32768MB
00:00:00 57MB | macOS 10.15.4 "Catalina", Darwin kernel 19.4.0
00:00:00 57MB | soft limit for open files raised from 10238 to 10238
00:00:00 57MB |
00:00:00 57MB | [hick] Start
00:00:00 57MB | [hick] Received: log_verbosity: 7942
00:00:00 57MB | [hick] Received: log_console_enable: 1
00:00:00 66MB WARNING | unable to load dynamic library: dlopen(/Users/chang/htoa/htoa-5.1.1_r126b954_houdini-18.0.391/htoa-5.1.1_r126b954_houdini-18.0.391/arnold/drivers/driver_houdini.dylib, 5): Library not loaded: @rpath/libHoudiniUT.dylib
Referenced from: /Users/chang/htoa/htoa-5.1.1_r126b954_houdini-18.0.391/htoa-5.1.1_r126b954_houdini-18.0.391/arnold/drivers/driver_houdini.dylib
Reason: image not found
00:00:00 66MB ERROR | [ass] line 28: node "driver_houdini" is not installed
00:00:00 66MB WARNING | rendering with watermarks because the skip_license_check option was enabled
00:00:00 77MB ERROR | [aov] output references a non-driver node: /out/arnold1:ip
00:00:00 77MB ERROR | [aov] no valid output statements found
00:00:00 77MB WARNING | failed to launch bucket workers: received abort signal


My issue is whenever I hit render on Arnold ROP it displays this, aborting the entire render.


It seems like driver_houdini.dylib dynamic library file that is included with Arnold for Mac can not be installed properly in this case.


Some of you told me to try Arnold 5.2.1, yes I tried with it and it is still the same.

Now I can't think that this is just the compatibility issue with Arnold and steam version of Houdini on macOS.


If you can recommend any methods to resolve this issue, that would be greatly appreciated.


If you are planning to buy Steam version of Houdini, don't buy it. I wasted $249 worth of money which they don't work together.

htoa arnold houdini
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

0 Answers

· Write an Answer

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.