question

外塚 勇己 avatar image
外塚 勇己 asked ·

maya xgen ass data not rendering in Houdini

Hi i'm trying to render xgen generated hair ass data in houdini but unfortunately this throws some errors. I could not find any thing about this in htoa documentation .it looks like needs some external setup besides default setting done on installation time .

Do you guys have any idea on this?

Thanks

houdinihtoahair
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Lee Griggs avatar image
Lee Griggs answered ·

What are the errors? What does the log file say?

1 comment Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Error log looks something like this .

ropNodeError_log.txt

houdiniConsole_log.txt

0 Likes 0 · ·
Stephen Blair avatar image
Stephen Blair answered ·

You also have to add the MtoA procedurals folder to the Procedural Search Path.


And then get an Arnold log that shows what happens when the ass file is loaded.

1 comment Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

yes i tried that one too , but still not working

0 Likes 0 · ·
systemv.png (632.3 KiB)
system.png (709.4 KiB)
Stephen Blair avatar image
Stephen Blair answered ·

The ASS file has MtoA-specific shaders. So you need to add the location of the MtoA shaders (like MayaChecker) to the plugin search path.

And XGen requires Maya libraries, so you need to add some Maya folders to PATH.

For example:

https://arnoldsupport.com/2018/02/02/maxtoa-rendering-xgen-in-3ds-max/

1 comment Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Actually i tried this one . i added them to my system environment variable path but unfortunately did work for me.

0 Likes 0 · ·
systemv.png (21.9 KiB)

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.