question

Alan Camerer avatar image
Alan Camerer asked ·

3DS MAX 2019: Map to Material and Shadow Matte Transparency

3ds Max 2019: I have added a floor for my scene to accept shadows only by giving it a Map to Material with a Shadow Matte input as a material. I have some translucent syringes and bottles that are working great, giving me the alpha output I need for inserting the images on a PPT background - except where they cross the floor object, which makes them opaque (pipettes, bottles and syringes) - I left the floor small so you can see the line. Here's the alpha map for reference:


And on the PPT background. Just want the shadows without losing the object transparency. TIA for any info!


materials3ds maxtransparencyshadow matte
alpha-map-sample.png (324.4 KiB)
onpptbackground.jpg (53.7 KiB)
shadowmatte.png (29.3 KiB)
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

1 Answer

· Write an Answer
Mads Drøschler avatar image
Mads Drøschler answered ·

The reason that the alpha is broken is because you haven't instructed the matte to be invisible in Transmission.

In order to do that, you add an Arnold Properties modifier to the matte plane that catches the shadows, and enable the ray section in the top and disable Transmission.

I did a quick test here, the glass has correct alpha to background so I can stick images behind the render and get the correct glass effect on top, I also don't have the white matte plane in the transmission rays, so all you get is full mesh alpha and no obstracles.

Make sure to set the environment to Either Custom map or Arnold Shader with NO shaders plugged in, this triggers the alpha to penetrate correctly, else you will get a wrong result. ( alpha will remain solid if its default "scene environment" )


qwe.png (534.5 KiB)
2 comments Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Bravo Mads! You got me out of my mental loop. I knew it was probably some setting I was missing. Adding the Arnold Properties to the plane was the solution! I also had Custom Color to White in Arnold Backplate settings. Setting to Custom Map with None worked.

Thanks so much for the detailed answer.

Have a great week!

Regards,

Alan

1 Like 1 · ·

Super, you too.

0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.