question

Tom Last avatar image
Tom Last asked ·

Cant render with GPU

Getting this fatal error when trying to render with GPU with newest Arnold build. Couldnt render in the last version, too.


Was told, whatever the reason for this was fixed in this issue.

Further information here:

https://forums.autodesk.com/t5/3ds-max-shading-lighting-and/textures-in-viewport-messed-up-after-upgrading-2021/td-p/9564813/page/1



rendergpuerror
13 comments
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

I don't see what driver you are using.

0 Likes 0 · ·

This one:

0 Likes 0 · ·

That long thread on the Autodesk forums is about the viewport and UVW, no?

Does any scene crash GPU on your machine?

How about a scene that doesn't use all the unsupported nodes and shaders? Even if it did render, wouldn't not look right?

0 Likes 0 · ·
Tom Last avatar image Tom Last Stephen Blair ♦♦ ·

It started as viewport and uvw issue, but turned into a GPU related issue and persists.

When rendering default materials from the slate slots there is no issue.

The nodes and shaders were recommended to me as the best solution for viewport/rendering. I dont know if they are unsupported. What do you mean with no looking right?


Meanwhile their is another error type:

[Arnold]: 00:00:08 4989MB ERROR | [gpu] OptiX exception: Invalid value (Details: Function "_rtTextureSamplerSetBuffer" detected error: Invalid object "buffer")

0 Likes 0 · ·

Is this the latest version of Arnold? A new version was released this week, so it's always possible that crash has since been fixed.

0 Likes 0 · ·
Show more comments

So is this still buggy or is there any way to solve this issue?

0 Likes 0 · ·

Hello could i get some support here plz?

0 Likes 0 · ·

Can you be a little bit more specific of what is happening? Are you using OSL bitmap with Arnold GPU?


0 Likes 0 · ·

I did a whole thread about it on the autodesk forums, specifying the issue
https://forums.autodesk.com/t5/3ds-max-shading-lighting-and/textures-in-viewport-messed-up-after-upgrading-2021/td-p/9564813/page/1

There i was told to use OSL maps in general, which didnt solved this. Then the issue was reported and fixed in the next version, so i was told, but nothing changed...

What other information can i add?

0 Likes 0 · ·
Show more comments
Tom Last avatar image
Tom Last answered ·

If needed here is a debug log from last render try with GPU:


00:00:54 5858MB | log started Fri Aug 7 00:00:50 2020
00:00:54 5858MB | Arnold 6.0.4.0 [3fad32b9] windows icc-17.0.2 oiio-2.2.1 osl-1.11.6 vdb-4.0.0 clm-1.1.1.118 rlm-12.4.2 optix-6.6.0 2020/07/31 08:11:38
00:00:54 5858MB | running on TS, pid=276
00:00:54 5858MB | 1 x Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz (4 cores, 8 logical) with 32706MB
00:00:54 5862MB | NVIDIA driver version 451.77 (Optix 60600)
00:00:54 5862MB | GPU 0: GeForce GTX 1070 @ 1683MHz (compute 6.1) with 8192MB (3816MB available) (NVLink:0)
00:00:54 5862MB | Windows 8 Professional (version 6.2, build 9200)
00:00:54 5862MB | soft limit for open files is set at 2048
00:00:54 5862MB |
00:00:00 5862MB | log started Fri Aug 7 00:00:50 2020
00:00:00 5862MB | Arnold 6.0.4.0 [3fad32b9] windows icc-17.0.2 oiio-2.2.1 osl-1.11.6 vdb-4.0.0 clm-1.1.1.118 rlm-12.4.2 optix-6.6.0 2020/07/31 08:11:38
00:00:00 5862MB | running on TS, pid=276
00:00:00 5862MB | 1 x Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz (4 cores, 8 logical) with 32706MB
00:00:00 5862MB | NVIDIA driver version 451.77 (Optix 60600)
00:00:00 5862MB | GPU 0: GeForce GTX 1070 @ 1683MHz (compute 6.1) with 8192MB (3816MB available) (NVLink:0)
00:00:00 5862MB | Windows 8 Professional (version 6.2, build 9200)
00:00:00 5862MB | soft limit for open files is set at 2048
00:00:00 5862MB |
00:00:00 5862MB | loading plugins from c:/programdata/autodesk/applicationplugins/maxtoa_2021 ...
00:00:00 5862MB | alembic_proc.dll: alembic uses Arnold 6.0.4.0
00:00:00 5862MB | cryptomatte.dll: cryptomatte uses Arnold 6.0.4.0
00:00:00 5862MB | cryptomatte.dll: cryptomatte_filter uses Arnold 6.0.4.0
00:00:00 5862MB | cryptomatte.dll: cryptomatte_manifest_driver uses Arnold 6.0.4.0
00:00:00 5862MB | MAXtoA_Adapter.dll: Max_Adapter uses Arnold 6.0.4.0
00:00:00 5862MB | MAXtoA_Shaders.dll: Max_UVGenerator uses Arnold 6.0.4.0
00:00:00 5862MB | ProceduralOperator.dll: procedural_operator uses Arnold 6.0.4.0
00:00:00 5874MB | usd_proc.dll: usd uses Arnold 6.0.4.0
00:00:00 5874MB | loaded 8 plugins from 6 lib(s) in 0:00.09
00:00:00 6114MB |
00:00:00 6114MB ERROR | [gpu] Fatal GPU error occurred, please restart the host application
00:00:00 6114MB | [color_manager] no color manager is active
00:00:00 6114MB | [color_manager] rendering color space is "linear" with declared chromaticities:
00:00:00 6114MB | r(0.6400, 0.3300) g(0.3000, 0.6000) b(0.1500, 0.0600) and w(0.3127, 0.3290)
00:00:00 6120MB |
00:00:00 6120MB | rendering image at 1280 x 720, 3 AA samples
00:00:00 6120MB | AA samples max <disabled>
00:00:00 6120MB | AA sample clamp 10
00:00:00 6120MB | diffuse samples 5 / depth 5
00:00:00 6120MB | specular samples 3 / depth 5
00:00:00 6120MB | transmission samples 2 / depth 8
00:00:00 6120MB | volume indirect samples 3 / depth 5
00:00:00 6120MB | total depth 10
00:00:00 6120MB | bssrdf samples 2
00:00:00 6120MB | transparency depth 10
00:00:00 6134MB |
00:00:00 6134MB | releasing resources
00:00:00 6121MB | unloading 6 plugins
00:00:00 6121MB | closing alembic_proc.dll ...
00:00:00 6120MB | closing cryptomatte.dll ...
00:00:00 6120MB | closing MAXtoA_Adapter.dll ...
00:00:00 6120MB | closing MAXtoA_Shaders.dll ...
00:00:00 6120MB | closing ProceduralOperator.dll ...
00:00:00 6120MB | closing usd_proc.dll ...
00:00:00 6118MB | unloading plugins done
00:00:00 6118MB | Arnold shutdown

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

Plane001 is using OSL shaders. Hide that object, and the scene renders.


maxto-gpu.png (446.4 KiB)
2 comments Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Deleting the plane wont make it render with GPU. I dont know how you did it, but for me its still not working and throws the same errors, especially in my project scene. Even the image you rendered seems buggy, because rendering with CPU the eyebrows are different for e.g.

Never thought working with this GPU renderer would be that complicated and frustrating....


0 Likes 0 · ·

It's the OSL shaders on the plane that cause a crash. On my machine, with 11GB, three or more layers crash. I've logged a bug for this, because it's not the same thing described by Mr. T.

I'm rendering without textures, with the shader tree that is on that object.

0 Likes 0 · ·
A. C. avatar image
A. C. answered ·

I have reported the same problem back in april

https://answers.arnoldrenderer.com/questions/25198/gpu-maxtoa-40436-bugserrors-with-osl-hdri-environm.html

For me this is reproducable 100% of the time when rendering on GPU using OSL: HDRI Environment and/or OSL: Bitmap Lookup/UberBitmap.

For some reason the IPR session works completely fine on first attempt but the error only happens upon stopping/closing IPR and restarting it.

5 comments Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Couldnt reproduce it with this. With what did you replace them?

0 Likes 0 · ·

Try this:

1. Empty scene, then create a cube and apply physical material to the cube with a bitmap lookup texture plugged into the base color.

OR

2. Empty scene, then create a cube and apply physical material to the cube, press 8 to open environment settings and use a OSL:HDRI Environment map to apply a HDRI environment.


Then start either Activeshade or Production Arnolds RenderView IPR Session.

Wait till it starts rendering, usually the first attempt runs fine. Stop RenderView IPR/Activeshade close the window and restart it again.


I get a Cuda Error 100% of the time

0 Likes 0 · ·
arnoldgpuerror.png (345.4 KiB)

Yea now i can reproduce it, but could you solve this? Also getting rid of these maps just works on empty scene and sadly not in my actual project.

0 Likes 0 · ·
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.