question

Davide Bestetti avatar image
Davide Bestetti asked ·

PC freeze while rendering

Good morning
I'm experimenting a problem that is afflicting my second machine.
While rendering with Maya-Arnold the PC freezes after 10-30mins, and all i can do is hard reset it turning off the power button near the PSU.

Following my system specs:

Windows 10 with latest updates
Maya 2020.3
MtoA 4.1.0

AMD Ryzen Threadripper 2990wx
128 GB RAM
NVIDIA 1080TI
AMD X399 SLI PLUS as motherboard

Firstly i though it was a temperature problem. I checked them several time but freezing happens with good temperatures (CPU at 56-58°C)
I then though it was a displacement problem: the scene i was trying to render has several displacements in it, and freezing was happening often after the conclusion of a frame and the start of the next frame.
Disabling almost all displacements did not solve the problem, although it rendered for a longer time. (30mins)
I tested if the problem persists with an extreme simple scene: plane + cube + skydome, samples very high so render times went around 10-15mins per frame.
Freezing still happens.
I then tryed a stress test: downloaded prime95 and performed a CPU + RAM stress test.
The pc run all the night without a problem with CPU @100% and memory full whole the time.


Any advices to solve this problem?
Thanks in advance for any help

arnoldmtoa
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Thiago Ize avatar image
Thiago Ize answered ·

Aside from HW problems, the only thing I can think of is that you ran out of RAM, are swapping, and that makes the computer really slow. But even then it's not actually hung. The mouse should still move for instance and once in a while you'll be able to do something. Can you run the activity monitor and see what it says once you hang?

There are other ways for HW to fail than would be exposed by prime95.

Some suggestions:

  • Try running without maya. Uses the arnold supplied kick binary to run your simple scene from command line. If that works, then we know to focus on the maya/mtoa part of it.
  • Does it hang if you run with 64 render threads? What about 32, 16, 8, ... all the way down to just a single thread?
  • Can you run it in windows safe mode?
4 comments Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Hi Thiago! Thanks for your answer and help.
I tried several methods you suggested:

1)I could not run it in safe mode
2)The "complex" scene crashes even with only 4 threads active
3)With the batch i got some interesting results:

-the complex scene (with displacements) crashes anyway.
-the simple scene doesn't crash, i have been rendering it for 12hours; i then stopped.

at least we can now say that it's not a hw problem?
what would you suggest to do next? i would try to reinstall maya-arnold, but i already reinstalled windows some days ago hoping to fix this damn problem..


again thanks

0 Likes 0 · ·
Thiago Ize avatar image Thiago Ize Davide Bestetti ·

Can you try simplifying the complex scene until it stops hanging? That could help pinpoint what could be wrong if it's your scene. However, since your simple scene was crashing in maya, I still think this could be a HW problem and the simple scene with kick just didn't manage to tickle that problem?

Just to be sure, you're doing a CPU render, nothing GPU, right? Can you do the kick render with `-dw` so that nothing is displayed to the screen?

Examples of HW issues: Overclocking and/or using AMD or bios supplied tools that "tune" your system for speed.

1 Like 1 · ·

Thiago, i think we got a winner
The problem is: overclocking
I downloaded Ryzen Master to force the clock speed to factory defaults (3ghz) and it doesn't crash anymore.
The shop that sold me this workstation made an overclock to 3.3ghz. I was aware about this setting and for more than a year i could render almost everything without any problem.
That is why i never though about overclocking as main cause.
I don't know what it happened (i never changed anything in the bios) but the system went evidently unstable.


Thank you for your help and patience! Much appreciated :)))

0 Likes 0 · ·
Show more comments
Davide Bestetti avatar image
Davide Bestetti answered ·

Ok, i'm getting a bunch of errors.

11/18/2020 5:27:35 PM Critical The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

[This is the forced shut down, and just before]


11/18/2020 5:27:33 PM Error The description for Event ID 56 from source Application Popup cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.


If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

ACPI

15
The message resource is present but the message was not found in the message table


11/18/2020 5:27:40 PM Error The previous system shutdown at 5:07:05 PM on ‎11/‎18/‎2020 was unexpected.

[although the pc frozen for the first time today @5.27PM, i left it whole day in idle, so this last error doesn't seem to be correct]

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Max Tarpini avatar image
Max Tarpini answered ·
1 comment Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

the answer here has limited characters so i put the log just above

0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.