question

Tim Borth avatar image
Tim Borth asked ·

Problems with multi GPU

Hello there!
I added a second GTX 1060 6GB to my system and now renders will crash the second I start them. The error code is the following:

// Error: [gpu] an error happened during rendering : Unknown error (Details: Function "_rtContextLaunch2D" caught exception: Encountered a CUDA error: cudaDriver().CuMemcpyHtoD( dstDevice, srcHost, byteCount ) returned (700): Illegal address, file: <internal>, line: 0) //

Both GPU´s work fine on their own.
Windows 10 Pro 64Bit 2004 / 120.2212.31.0
Intel core i5 8600k@4,9 Ghz

48GB DDR4 Ram

Nvidia Geforce GTX 1060 6GB Asus Dual

Nvidia Geforce GTX 1060 6GB Asus Dual

No oc on GPU´s

Studio Driver Version 457.30

Newest Maya and Arnold version.

gpuerror
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Tim Borth avatar image
Tim Borth answered ·

Ok, so ive managed to narrow the issue down to textures. Without textures, any scene is fine. But if I add any texture to even a simple cube, it crashes 100% of the time. Maybe that helps.

2 comments
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

@Tim Borth
Thanks, this sounds like the other case we have, where it's texture related.

0 Likes 0 ·
Tim Borth avatar image Tim Borth Stephen Blair ♦♦ ·

Here is some extra info:

The second GPU is running at 4x 3.0 speeds, the first is running at 16x.

Neither the cards, nor the motherboard support sli.


Any idea if this is going to be fixed? It would be a bummer if I just bought another card for absolutely nothing. No worries though, thanks for helping me!


0 Likes 0 ·
Tim Borth avatar image
Tim Borth answered ·

A simple cube is fine. All in all I can say that maya has become VERY instable since I added the second card as render device. But again one is fine. If I extract some elements of the scene I wanted to render in the first place it was fine until I imported something with textures and not simple StandardSurface Shader. After that it crashes without fail.

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

We've had a couple of reports like this (one card is fine, two crash) and we're looking into it.

Does this happen with any scene?

Thanks for reporting.

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.