question

Konstantinos Chtenelis avatar image
Konstantinos Chtenelis asked ·

Exported images with transparency problem

I render my images with nothing in the background so I can put whatever I want afterwards in photoshop. I use depth of field so my model gets blurred. This blue background in the arnold renderview is just a color I choose in the arnold renderview settings. I put the same color in photoshop and this dark outline appears. I tried almost every image type.
Is there a way to fix this?

screenshot-2.png

renderview
screenshot-2.png (1.3 MiB)
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Hyper Vktr avatar image
Hyper Vktr answered ·

Maybe try Nuke instead photoshop ?

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Konstantinos Chtenelis avatar image
Konstantinos Chtenelis answered ·

In nuke when i uncheck premultiply it improves a lot but still is not perfect.screenshot-1.png


screenshot-1.png (553.0 KiB)
1 comment
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Try using black in arnold BG instead of any color, if needed use a blue light instead of the BG for a subtle tint.


In nuke try using the unpremult node instead of the checkbox, you will have more options.

1 Like 1 ·
Konstantinos Chtenelis avatar image
Konstantinos Chtenelis answered ·

I will try nuke in the future. Thanks for the answer!

2 comments
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

You will definitely be able to sort this with a few clicks in Nuke, I have no clue how it would work in photoshop :)

1 Like 1 ·

In Nuke you need to premultiply and in Photoshop the best option you have is to render the image with background as black so it doesn't show. Otherwise you will always have that edge. Which can also be removed in Photoshop using the menu Layer - Matting.

0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.