question

David Desousa avatar image
David Desousa asked

Arnold version 4.3.1.20 camera viewport bug

Since updating my version of max to Arnold for Max 2020.3 to the current 4.3.1.20 there is a consistent bug as follows: Upon re-opening a Max scene, every single camera view in the entire scene is wrong. That is, the view shown for each camera is completely off from where it was since the scene was last saved. This is true for both standard cameras and physical cameras. In troubleshooting this a little I discovered that if I click with the middle mouse button on the camera viewport (i.e., a small pan), the camera view jumps back to it’s correct position. And I can then undo the camera pan to make sure that the camera view is exactly where it should be. So this is apparently an initial “display” issue because the scene obviously “remembers” the correct orientation of the camera, but needs a click with the idle mouse button to refresh it’s memory.


Obviously this is tedious to do it for a scene with 20 cameras and does not happen with any previous versions of Arnold. Also, if I correct the camera views using the middle click technique/undo Pan technique described above and then render any view with Arnold, then the next time I open the scene, the camera views are all incorrect again and I have to reset each one. However, if I change the renderer to Scanline before saving the scene, then when I reopen the scene the camera views are all correct and I can change the renderer to Arnold without any problem with the cameras. Obviously this is an annoying bug and I would rather not have to remember to change the render engine to scanline for my last save of a scene so that the camera views are not messed up the next time I open the scene . I have not seen any reports of this bug yet. I am currently running Max 2020.3 on my system.


My system specs are:

ASUS P9X79 WS Motherboard

Intel Core i7-3930K @ 3.2 GHz (not overclocked)

Windows 7 Professional Service Pack 1

32 GB RAM

GeForce RTX 2060 Gaming Z 6G


Any guidance on how to fix this would be greatly appreciated. If it is a bug, then please consider this a bug report or advise where I should submit it.


One other thing I noticed with Max to Arnold version 4.3.1.20 vs version 3.2.65 is that my RTX 2060 Graphics card shows up in the System Tab > Manual Device Selection for version 3.2.65, but for the current 4.3.1.20 it does not show up at all. I mention this only because the initial display problem with the camera viewports seems like it might be tied to the graphics card in some way.

Is it expected that Max to Arnold version 4.3.1.20 would no longer show a previously recognized graphics card in the window shown in the attachment?


Thanks in advance for any help.

viewportcameras
1615130617241.png (100.3 KiB)
1 comment
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

The older scenes were created with MAXtoA 3.2.65 ?
Or can we use a more recent version of MAXtoA to test this?

0 Likes 0 ·
David Desousa avatar image
David Desousa answered

I have confirmed that the issue occurs also with a new scene with cameras in Max to Arnold version 4.3.1.20. You must close out completely out of max and then when you reopen max the next time and open the scene, the issue occurs. Simply resetting Max without ending the Max session and then reopening the scene does not give the issue. Thanks for looking into this.

4 comments
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Hi

I don't repro with 3ds Max 2021.2 and MAXtoA 4.3.1.20

I'll update to 2021.3

0 Likes 0 ·
David Desousa avatar image David Desousa Stephen Blair ♦♦ ·

Stephen,

After creating the cameras, the scene must be rendered with Arnold as the renderer. Then after saving the scene close down Max. The next time you open the scene the issue appears for me. However, I am using Max 2020.3 and not Max 2021.

0 Likes 0 ·

So far I have not reproduced the problem. My test scene has 14 physical cameras. I render (with Arnold Render View or Render Setup > Production), save the save, restart 3ds max).

I'll install 2020.3 and try with it.

0 Likes 0 ·
Show more comments
David Desousa avatar image
David Desousa answered

Thanks Stephen for working on this (and for the sanity check).

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.