question

Edwin Fuhrmann avatar image
Edwin Fuhrmann asked ·

Heat/Fire from x particels not showing in final render

Hello there.

I have a problem with a explosiaFX sim in xparticels...I have a scene with a sphere as the xplosia source and and the standart xplosia sim in the xp system. there is the arnold tag and the volume shader on the xplosiaFX sim and the density channel is set to smoke and the emisson channel to fire---when i run the ipr everything is fine and the smoke has it´s color and i can adjust the intensity/color of the flames...allthoguh when i cash the sim and run the ipr afterwards the smoke is fine but the fire completly disappears...

do you have any idea where the problem could be? thanks in advance

x-particles
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Edwin Fuhrmann avatar image
Edwin Fuhrmann answered ·

uncached-27.pngcached-27.png

so the first one is not cached and fire/smoke work fine. the second one is cashed and somehow the fire is missing...i don´t know why there is the white on the floor maybe because of the quick snapshot export...


cached-27.png (486.3 KiB)
uncached-27.png (508.2 KiB)
1 comment
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Can you reproduce it in a simple scene as well? I've tested a simple sim and the fire was rendering fine from the cache.

Can you send me your scene maybe?

0 Likes 0 ·
Edwin Fuhrmann avatar image
Edwin Fuhrmann answered ·

okay the fire wont´render in the sim when it´s cached....i tried it with and wihout the volume shader on it and in both cases there is only the smoke rendering. when i disable the cache and render everything is fine and the volume shader with the smoke/heat works and everything looks fine...so there must be a problem withe cache right? any ideas?

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Peter Horvath avatar image
Peter Horvath answered ·

First I would check if the heat/fire channel is written to the cache properly. Try to render the cached sim with another renderer (e.g. Standard or Physical)

It it's there, maybe it's a scale problem, so you can try increasing the emission Intensity in the volume shader.

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.