question

Edwin Fuhrmann avatar image
Edwin Fuhrmann asked ·

XP trails geometry not working correctly?

Hello there...

Actually this should be no problem but when i apply the arnold tag on the xp trail object i don´t get round splines...instead the splines get flat and i am not albe to figure out where the problem is...in every video the tag is applied and it works fine but not for me...tried a couple things but i really have no idea what the problem is...maybe you can help me---take care and greetings-snapshot-000.jpg

x-particlestrails
snapshot-000.jpg (460.6 KiB)
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Edwin Fuhrmann avatar image
Edwin Fuhrmann answered ·

short edit:

i tried to use some custom shapes in the arnold tag on an emitter but they also don´t work...is the problem that they are editable because the standart c4d shapes are all working.

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Peter Horvath avatar image
Peter Horvath answered ·

Just to be sure, did you change the Mode to thick in the Arnold tag?

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Edwin Fuhrmann avatar image
Edwin Fuhrmann answered ·

No it´s on ribbon. actually i did not change anything in the tag....i put the trail into a spline mesher and it kind a works now but is super heavy because of the poly count of the splines...

should be possible without putting it in a spline mesher right?

greetings!

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Edwin Fuhrmann avatar image
Edwin Fuhrmann answered ·

hello again...

so finally i set the mode to thick and it works fine...one last question allthough there are some other posts about but it does not work for me:

i want to random the colors and use the setup with the utility shader (random id) and it works fine..is it possible to define a certain color spectrum like with a color jitter note? i put the utility shader in the color jitters hue min and set the color and try to play with the values and it semi works...maybe you have some final tip for me but thanks as always for your help!

1 comment
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

You can actually use a color_jitter shader, just read the curve_id via a user_data_int shader and connect it to the User Data / Data parameter. Make sure Export IDs is enabled in the Arnold tag of the xpTrails.

1624637002857.png

0 Likes 0 ·
1624637002857.png (252.4 KiB)

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.