question

Joshgeorge1971 Joshgeorge1971 avatar image
Joshgeorge1971 Joshgeorge1971 asked ·

can someone explain how I can add opacity to a utility shader?

,if I want to create a custom AOV but use the opacity matte that I have plugged into the standard surface..I cant work it out at all..I am sure it must be pretty simple but i am really stuck...SItoA by the way thanks,Hi ..having an issue with Utility shader and Opacity..

aov
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Robert Mastny avatar image
Robert Mastny answered ·

I just checked in 5.0 an indeed the opacity slot is gone.

Just plug the utility shader in the "out color" slot of a surface shader and connect the transparency map to the "out transparency". That works for me here.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Joshgeorge1971 Joshgeorge1971 avatar image
Joshgeorge1971 Joshgeorge1971 answered ·

Hi..so this works..but it does feel a bit clunky, having to use standard surface and a custom AOV just to get opacity on a flat shader..if anyone knows a more simple approach please let me know..thanks for the help so far


opacity.jpg (241.3 KiB)
Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Joshgeorge1971 Joshgeorge1971 avatar image
Joshgeorge1971 Joshgeorge1971 answered ·

hi thanks for the reply..just switched to arnold 5..and the opacity slot has been removed..yes 'opaque' is off ??

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Robert Mastny avatar image
Robert Mastny answered ·

Maya user here with Arnold 4.x;
I have an opacity slot in my Arnold utility shader that works flawlessly.

Stupid question: Have you un-ticked the "opaque" option in the Arnold settings in the shape? I'm sure there is some equivalent in SI; in Maya you have to tell Arnold that a specific model has transparency, otherwise transparency does not work with that object.

1 comment Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Test comment.

0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.