question

Ariff Jeff avatar image
Ariff Jeff asked ·

Arnold setting toggle logic - Obscure bug?

c4dtoa-togglelogicbugc4d.zip

The best way for you to understand this bizarre problem I am having is to check out the attached C4D file and follow the steps below:

1. Open C4D file (contains default Arnold render settings)

2. Notice how the cylinders are all black except one tiny part of one instance

3. Select the texture tag that is on the Cloner object

4. Enable "Tile"

5. Disable "Tile"

6. Notice how enabling Tile made the cylinders completely colored as expected. But notice how disabling Tile did not revert the colors back to all black and a tiny colored part. This is the problem that is confusing me. Is this a bug?

7. Select the Cloner object

8. Enable "Render Instances"

9. Disable "Render Instances"

10. Now we are back to our initial almost all black cylinders.

What I want to know is what is causing the settings in my list above to act unpredictably when toggled on and off (in relation to the context of the texture of the cylinders). I have never encountered this issue before and it took me a decent amount of time to figure out why toggling a setting on then off would not accordingly change a texture to another state and then back, as logic would demand. What is going on here?

I am using a MacBook Pro - C4D R19 Student - C4DtoA 2.3.0.1 - Arnold core 5.1.0.1

Thank you!

c4dtoatexture
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Peter Horvath avatar image
Peter Horvath answered ·

The issue exists in the IPR, right? I can confirm that it does not update properly when changing the Tile on the texture tag, which looks like a bug. Render to the Picture Viewer however shows the expected result. I'll try to fix this in the next release.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Ariff Jeff avatar image
Ariff Jeff answered ·

Yes, sorry I forgot to specify that I left the IPR window open and rendering through every step of this process. I was only ever looking at the IPR window the whole time. Thank you for taking notice of this strange issue!

Also just being curious, are you leading the development of C4DtoA/how many people are developing this plugin?

Thanks, Peter!

2 comments Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

I'm the only one working on the plugin specifically. So yeah, we can say, I'm leading the development. ;)

1 Like 1 · ·

Well you're doing a great job! Thank you for your work! I love the plugin!

0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.