question

Greg Hughes avatar image
Greg Hughes asked ·

Mesh light shadow problem

I find that if I use an Arnold Mesh light, a Maya Directional light will cast shadows off the mesh item you used for the light. Is there any way to swiitch off the shadow?

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Edward Conry avatar image
Edward Conry answered ·

Hey, you just need to turn off cast shadows. It's under the shape node, Arnold tab, visibility, and uncheck cast shadows.

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Greg Hughes avatar image
Greg Hughes answered ·

@Edward Conry

I already tried that, it makes no difference (Maya 2017/Arnold 5). The only thing that worked was to turn off Casts shadows for the directional light. It does not work if you switch it off Casts shadows on the mesh itself.

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Edward Conry avatar image
Edward Conry answered ·

Ok I got it to work. Use your mesh with an aiStandard surface and the emission weight and color(not mesh light). Than you can turn off cast shadows. You can also use aov or render layers to add the mesh lights in comp. But that might get a little bit messy.

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Edward Conry avatar image
Edward Conry answered ·
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Greg Hughes avatar image
Greg Hughes answered ·

@Edward Conry

Sorry, I don't follow what you mean.

- Use your mesh with an aiStandard surface and the emission weight and color (not mesh light)?

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Edward Conry avatar image
Edward Conry answered ·

There's the mesh light under the Arnold menu, there's changing the shape from mesh to mesh light, and then there's turning on emission on the shader. If you use the shader than uncheck cast shadows on the shape node that would get you what you want.

@Greg Hughes


meshlight.png (856.5 KiB)
2 comments
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

@Edward Conry

Thanks for your.. eh hem... illuminating answer.

I see what you mean now.

0 Likes 0 ·

Hi! I have exactly the same issue. I understand the workaround with an emission shader but it's not really optimised. Do you have some news about it?

Thanks!

0 Likes 0 ·
Stephen Blair avatar image
Stephen Blair answered ·

For the light sampling to work properly, a mesh light has to be visible to shadow rays (which means the mesh light will cast shadows).

If you make a mesh light invisible to all rays, you'll have no shadow but you'll see this warning in the Arnold log:

light_pTorus1Shape: for MIS to work properly, polymesh linked to mesh_light should at least be visible to shadow rays
2 comments
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Thanks for your answer Stephen!

But I don't see this log when I disable cast shadow from the attribute editor of the shape: shape / Arnold / visibility / Cast Shadows. (echo all command enabled)

Did you do it in another way?

0 Likes 0 ·

You need to know the name of the mesh that is exported to Arnold. It will be something like "light_pTorus1Shape@mesh"
Export an ass file to check the name.
Then use an operator to set visibility on that mesh.

But that warning means that light sampling won't necessarily work properly after you do that.

0 Likes 0 ·
Joachim Guerin avatar image
Joachim Guerin answered ·

Thanks! I got it now, it works on my side. Indeed, hope to don't have too much side effects!

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Jodie Garner avatar image
Jodie Garner answered ·

Unchecking cast shadows does absolutely nothing for me. It's really annoying because I don't want a giant shadow beneath my soft diffuse light with no object in sight that might cast one.

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.