question

Sina Mehralinia avatar image
Sina Mehralinia asked ·

Displacement

Hi everyone,
I have a problem with my displacement and Vectors map, which they don't show up in the render. They're fine in the lookdev scene but when refrenced in the shot they're just not working anymore.
I would appreciate your help!
Maya 2018
MtoA 3.1.1

shadersdisplacement
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

- The "sphere" works in the render scene?

- What's in the reference? The shape, the shape and the shaders?

- What do you get if you export the shape and shaders to ass? From lookdev and from render scenes? What's the diff?

- Do you see the vector displacement map being loaded (in the Arnold log image stats) for the render scene? Can you post the logs for both lookdev and render scene?

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Sina Mehralinia avatar image
Sina Mehralinia answered ·

It's not that kind of the problem, becuase when I assign the shader to a simple sphere displacement works on the sphere.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

You won't see an error in the log for a missing texture, not if you're using the file node.

How do you know the texture is being loaded? Did you check the image file statistics in the log?

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Sina Mehralinia avatar image
Sina Mehralinia answered ·

@Stephen Blair Everything is connected and "ignore displacement" is off and there are no error or warning in the log. Asset is organic and animated in the shot, but as I said before everthing works fine in lookdev.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

Maybe the texture map is missing. I'd check that out first.

Then check the Arnold log.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.