question

Ingo Polster avatar image
Ingo Polster asked ·

Flake Scale in Carpaint Shader

I have the problem that the Density i need is mostly around 0.00001
I found out that internal C4d works with much more decimal places than shown.
So if i type in 0.00001 its shown as a 0 but it works.
My question is
1. Why does Arnold make the Scale so big that you have to type in so tiny numbers? Or do i make something wrong? The model is in real world scale.

2. Is there a smarter workaround than that?

shader
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Peter Horvath avatar image
Peter Horvath answered ·

The default export scale is 1m to 1 Arnold unit. You can change it on the System tab of the Render Settings. I should probably change the default to a more reasonable 1cm, but it's not that trivial as it can break current scenes, so will be done probably in a major release.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Peter Horvath avatar image
Peter Horvath answered ·

Basically yes. But note, that if you change the export scale, you may need to scale some parameters as well, which depend on the distance, like the light intensity, volume density, etc.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Bruno Rantin avatar image
Bruno Rantin answered ·

This is probably due to either your scene scale or the conversion arnold is doing. Maybe your object is too small in the conversion?
I dont know about c4d, but in maya there is an attribute in the render options called render unit and scene scale that you can adjust to convert your scene scale for arnold renderer, C4DtoA should also have this attribute so you can adjust this to achieve more user friendly values in your shader without having to actually scale your entire scene.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Ingo Polster avatar image
Ingo Polster answered ·

Hey Guys, thank you so much!!
So if i understand you right i always have to keep the settings the same in C4d and Arnold.
Both meter or both centimeter to have the light and all maps react physically right.

In the manual is written:

"If you work with small objects (e.g. radius of 1 cm), you might need to change the export scale to 1 cm. This parameter affects all length unit values, e.g. vertices, camera and light position, displacement height, bump height, etc."

In this case i should still set both C4d and Arnold to 1 cm right??

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.