question

ahmed adel avatar image
ahmed adel asked ·

transmission depth takes sooooooooooooo long to start rendering in the gpu render!! (MTOA3.3.0.1)

when I put transmission depth value more than zero makes the GPU render starts after waiting soo much compared with the previous release, I love arnold Gpu Beta so much It is fast and just so right !
and I hope it will get better and better with every release !

mtoagputransmission
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Thiago Ize avatar image
Thiago Ize answered ·

It will be slow (maybe up to a few minutes) the first time you render that scene as it does the just in time compilation for the shader combination that you're using. After that, if you try and re-render the same scene it should be fast. If you look at the Arnold logs with sufficient verbosity setting set, you should get messages telling you why it's slow. Feel free to post your log here so we can see what's going on. It's possible there could be a bug we need to fix...

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Aaron Ross avatar image
Aaron Ross answered ·

A few minutes is way too long to wait for first pixel. Those few minutes add up. Pretty soon I've wasted a half hour or more of my day waiting for that GPU render.

6 comments Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

That should only happen the first few times. Then it should be fast, especially for simple scenes. Do post a log of your slow startup so we can see what's wrong and fix it. For reference, it is almost instant when I render a simple GPU scene on my machine.

0 Likes 0 · ·

I'm sorry @Thiago Ize yes it acctually slows down just with the very first time only
but also not so long like I mentioned may be it was a corrupted scene back then I don't know !! but when I try it now it works pretty well
thank you @Thiago Ize

0 Likes 0 · ·

log.txt
...

0 Likes 0 · ·
log.txt (8.9 KiB)

Good to hear it's now working as expected.

Thanks for supplying a log file, but unfortunately this isn't an arnold log file. Some instructions are here:

https://docs.arnoldrenderer.com/display/A5AFMUG/Log Note that you need to include "Info" verbosity level so we get the timing info.

1 Like 1 · ·
Show more comments
Aaron Ross avatar image
Aaron Ross answered ·

This past week I have spent a lot of time trying to get GPU rendering working well enough for material testing. Nothing fancy, just trying to get faster previews of material editing. I gave up. Even after jumping through many hoops (pre-populate GPU cache, use all Arnold lights and materials) it still takes FOREVER to get that first pixel. Even a trivial scene with no global illumination is super, super slow to start up. It's a waste of time. I wish I had never even tried, because I'll never get all of those hours back.

2 comments Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

yes, first time rendering takes soo long to start when you render big scenes but this problem I think if I'm not mistaken arnold promised us to solve with texture on demand loading

https://youtu.be/pQctj_5MWiY

but transmission depth even with a verybasic scene with no texture starts after so much wait !

0 Likes 0 · ·

Please post your arnold log so we can see why this is slow.

0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.