question

Wm. Josiah Erikson avatar image
Wm. Josiah Erikson asked ·

Registering MtoA on linux

Hi all,

I've just finished a frustrating bout of getting Maya 2018 and MtoA installed on our render farm, which is running CentOS 6.5. I thought I'd post my experience here so that this was documented somewhere on the web, since I couldn't find ANY reference to this anywhere else.

So I was able to get Maya installed and licensed by installing the RPMs and running

export LD_LIBRARY_PATH=/opt/Autodesk/Adlm/R14/lib64/

/usr/autodesk/maya2018/bin/adlmreg -i N 657J1 657J1 2018.0.0.F <serial> /var/opt/Autodesk/Adlm/Maya2018/MayaConfig.pit

as it says in the docs.

I then installed the MtoA plugin, using the docs here:

https://support.solidangle.com/display/AFMUG/Installing+Arnold+for+Maya+on+Linux

Very little about these docs worked. I was unable to find any more recent docs for this process either, even though these are four years old. It is not sufficient to set the environment variables mentioned in those docs. It is also necessary to set

MAYA_PLUG_IN_PATH=/opt/solidangle/mtoa/2018

in Maya.env for Maya to be able to find Arnold.

At this point, I could render with a watermark but licensing was clearly not working, so I turned to these docs, which are much more recent and seem to be up-to-date:

https://support.solidangle.com/display/A5AILIC/%5BCLM%5D+Setting+up+Autodesk+licensing

However, adding the ~/.flexlmrc file pointing to my license server was not sufficient by itself. I discovered, randomly, that I also had to run

/opt/solidangle/mtoa/2018/pit/pitreg

in order to get this to work. Either by itself was not sufficient (I had a lot of render nodes to double-check with), I had to do the ~/.flexlmrc AND the pitreg command. I'm posting here because if you google "/opt/solidangle/mtoa/2018/pit/pitreg" you get literally no results, so I figured this post might help somebody, and perhaps get the docs updated as well.

All the best,

-Josiah Erikson

render farmlinux
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

It is possible to do a silent install too: https://arnoldsupport.com/2017/10/23/mtoa-running-a-silent-install/

I'll copy that over to the docs soon...

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Mario Positano avatar image
Mario Positano answered ·

Thank you!

That .flexlmrc worked.

I also had to open up permission on /usr/tmp. Not sure what that wasn't open in the first place.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

Did you get an error for pitreg during the installation? Then you have to run

/opt/solidangle/mtoa/2018/pit/pitreg

If not, then you don't need to run pitreg.

All the other things you did won't help with licensing.

You need to edit ~/.flexlmrc and set ADSKFLEX_LICENSE_FILE:

ADSKFLEX_LICENSE_FILE=@192.168.29.36
Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Mario Positano avatar image
Mario Positano answered ·

Hello!

Unfortunately, I am still getting watermarks after trying the above solution. What is odd is that I am running a small pool (on our farm) twelve machines are rendering fine. Two machine are generating frames with water marks. The machine were all installed and configured the same way and they are all the same hardware. I tried uninstalling and reinstalling Maya and Arnold (MtoA-2.1.0.1-linux-2018.run) but I am still getting water marks on these two nodes. Any hints would be most appreciated.

Here is what I tried:

1. export MAYA_PLUG_IN_PATH=/opt/solidangle/mtoa/2018

2. /opt/solidangle/mtoa/2018/pit/pitreg

3. edit /var/flexlm/maya.lic (to point to the license server)

SERVER 192.168.29.36 0

USE_SERVER

4. /home/SRC/MAYA2018/adlmreg -i N 657J1 657J1 2018.0.0.F [lic number] /var/opt/Autodesk/Adlm/Maya2018/MayaConfig.pit

NOTE: I get this response: Serial Number exists. Skip registration.

5. ~/.flexlm

ADSKFLEX_LICENSE_FILE=/var/flexlm

tried this too:

ADSKFLEX_LICENSE_FILE=/var/flexlm/maya.lic

6. nano ~/maya/2018/Maya.env

MAYA_PLUG_IN_PATH=/opt/solidangle/mtoa/2018

Honestly, I thought a re-install would do it but even after all of this, two nodes are getting watermarks.

Any suggestions?

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Wm. Josiah Erikson avatar image
Wm. Josiah Erikson answered ·

Also kudos for the quick responses here. I'm very impressed.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Wm. Josiah Erikson avatar image
Wm. Josiah Erikson answered ·

Oh that's very useful information! Thanks very much for that. Probably now that I've already made the RPM, it's easier to just use that, but it's good to know that's an option.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Wm. Josiah Erikson avatar image
Wm. Josiah Erikson answered ·

I see, that makes sense. I had made an RPM because I need to be able to auto-install on reboot - this is a ROCKS cluster - so that explains it. So now this can be a "steps you need to take if you didn't use the installer but just zipped up the directory and made an RPM out of it so you could more easily install on your render farm" post. Of course now I'll just add that in the post-install section of my RPM... thanks for the clarification. Those docs made it sound like you had to do that, but I see that I was misunderstanding.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

You were looking at the old MtoA docs. But that doesn't matter because nothing much has changed.

The install itself is fairly simple, and should take care of everything for you. I rarely have support cases about Linux installs.

It's not necessary to set any environment variables. Everything should work with what's in the MtoA module file.

The installer runs pitreg automatically, so I assume you got some error?

Google pitreg or mtoa pitreg.

The third hit for mtoa pitreg is https://arnoldsupport.com/tag/autodesk-licensing/

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.