question

Daniel Mikolajcak avatar image
Daniel Mikolajcak asked ·

Textures show red in Viewport

Hello,
sometimes some textures show red in the viewport. It can go away if fiddled around with shader settings and some luck. Does anyone have same problem?

I run
c4d r21.115

C4DtoA 3.0.1.2 [9d6a6cbe]

Arnold core 6.0.1.1
Mac OS 10.15.3

textureviewportchinese
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Peter Horvath avatar image
Peter Horvath answered ·

This was reported before, seems like something has changed in Cinema 4D, and the textures are not loaded properly in the viewport sometimes when the scene loads. Only Mac is affected, R20 and R21. I'll ask Maxon again if it's something which has to be fixed on their side.

5 comments Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

It is very random, different textures are affected different times. Thanks for further investigating it.

0 Likes 0 · ·

Any news with the red texture display, Peter?
I tried to ask Maxon but they said this:

Hello Daniel,

We are very sorry, but we can't give you any support for thirdpaty plug-ins.
If you having issues with a plug-in, you have allways contact the developer directly.
The developer then, have to contact our development from his side directly over our developer support.
We are sorry for any inconvience.

0 Likes 0 · ·

Yes, it's fixed and will be released soon.

1 Like 1 · ·

This should be fixed now in C4DtoA 3.0.2.1, please let me know if you still have issues.

1 Like 1 · ·

it is fixed now, thank you for fast fix

0 Likes 0 · ·
Stephen Blair avatar image
Stephen Blair answered ·

Red is the texture error color, so I would check the Arnold log. Something happened loading the texture

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Daniel Mikolajcak avatar image
Daniel Mikolajcak answered ·

Hello Stephen, I have discovered the diagnostic tab. The file it produces when rendering is however 0kb. Do you have any tips on how to extract the error info?


1 comment Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Verbosity level is set to Warnings by default, which means only warning and error messages are written out. There's no error in Arnold currently, because your scene is fine, the problem is in C4D when the scene loads, so the file is empty.

0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.