question

David Cook avatar image
David Cook asked ·

Operators: losing shader assignment with multiple objects

Hi


I am using operators in a fairly complex scene.

I have many similar standins (a couple of hundred), and I have three shaders brought into the scene with aiIncludeGraph nodes.

I have a shader assignment script that randomly picks a Graph and assigns it to the operator slot of the standin. Render looks fine.


But - a few frames later the assignments are all jumbled up - well not all of them, just some of them. Not good!


All standins have unique names, I have tried this with very simple shaders and on different objects...what might be wrong?


Any help would be marvellous.


Thanks

Dave




MtoA 3.3.0.1 Maya 2018.3

shadersoperator
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

Try disabling the auto-instancing of procedurals.

In the Render Settings > Diagnostics, put this in the User Options:

enable_procedural_cache off


Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

David Cook avatar image
David Cook answered ·

Hi Stephen

Thanks for your reply. With my red, green and blue shaders, an object might be red on frame one, green on frame two and blue on frame three. Or it might stay red. I have not seen any objects with no shader so far.

And I am seeing it in IPR and renders to disk



Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered ·

I'm working a support case that sounds like the same problem.

When you say jumbled up...do you mean that some objects in the standin have the wrong shaders or no shaders, or that it's per standin?


And...just IPR or renders to disk?

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.