question

Tim Anderson avatar image
Tim Anderson asked ·

Increasing dynamic range in renders

I have been struggling with Arnold renders clipping badly – in order to get enough light I am having to increase light exposure and my highlights end up blown out.

I read a post about increasing the dynamic range in renders for Blender (https://www.blenderguru.com/tutorials/secret-ingredient-photorealism). This post mentioned the "Filmic Blender" colour configuration, which looks to be based on ACES. I assume this is the same path I need to follow for c4dtoa.


1. Base test

Here's a test render illustrating the issues I'm seeing, this uses the default 'color manager' settings:


2. Trying to setup ACES

I've tried to figure out how to get ACES working with c4dtoa – but I am failing. I have followed this post (https://cglines.blogspot.com/2020/05/how-to-aces-in-c4dtoa.html) loading, the ACES config:

but my output with these settings seems no better or different to the default test (am I missing a step after setting the ACES config?):


3. Using 'Blender Filmic'

I have tried loading the 'filmic' configuration, which was created for Blender, I assumed it would not work...and I couldn't really get it to do anything. However, I loaded the configuration and tried different selections and somehow got this result, which in terms of highlights and range is just what I'm after (although some textures are rendering incorrectly) – the problem is that I got this render to work, but I cannot replicate it, the config seems flaky and won't load and I cannot reliably replicate this output:

In short, is there something I am doing wrong in loading the colour manager config – it doesn't seem to be doing much, or it's flaky and I can't get the settings to stick.

Alternatively, am I barking up the wrong tree in trying to fix the dynamic range of my renders?

colorcolor space
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Lee Griggs avatar image
Lee Griggs answered ·

Are you rendering to EXR?


>I have followed this post loading, the ACES config:

This link does not work. Are you referring to this ACES page?


>(am I missing a step after setting the ACES config?):

This?



8 comments Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Sorry, link I followed for ACES setup was this post:

https://cglines.blogspot.com/2020/05/how-to-aces-in-c4dtoa.html

Does changing the IPR window Color Space affect the render?

0 Likes 0 · ·

Yes. Did you do this?

0 Likes 0 · ·

I did. However, I've just noticed that the console is returning this

color_manager_ocio] color spaces will be ignored due to rendering color space OCIO error (Could not find colorspace 'BT.1886 EOTF'.)

I am assuming this is why I have no change when loading ACES.

0 Likes 0 · ·
Show more comments
Lee Griggs avatar image
Lee Griggs answered ·
Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Tim Anderson avatar image
Tim Anderson answered ·

I'm not seeing any difference between a render with color manager set to ACES vs sRGB – but I do see the difference in the IPR. Perhaps I'm missing a key step. I'm outputting to EXR, am I wrong to assume the histogram should be different between the two in the picture viewer?

Here's results with default settings –

ACES test – render/histogram unchanged, IPR seems to be correct

My test file: https://www.dropbox.com/s/txs438iol884w39/ACES%20Test%20v2.c4d.zip?dl=1

screen-shot-2020-08-22-at-122616-am.png (1.5 MiB) screen-shot-2020-08-22-at-122717-am.png (1.6 MiB)
1 comment Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

As I said before, the ACES output color space transform is only visible in the IPR. If you render to the Picture Viewer, you will see the native sRGB transform added by Cinema 4D. (Unfortunately Cinema 4D does not support ACES).

If you want an output image with the ACES output space applied, then you can not use the native Sae option. Instead create an Arnold Driver (e.g. tiff) and set the color space there.

1 Like 1 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.