question

Vinicius Paciello avatar image
Vinicius Paciello asked

Lights not working inside Solaris

Hey folks. I'm studying this scene/USD assembly and using solaris. As I add lights, its like nothing happens with Arnold. Karma does light the scene properly. Tried to raise substantially the exposure to make sure it wasn't the problem, and no difference. The only visible light is a default one that ooks like a white dome. This one lights the scene and I can't seem to turn it off

It happened before but somehow I got away with it as far as I remember. Don't know how I managed to fix it. Do you guys know what might be causing it?

Using Houdini latest (18.5.633) and htoa latest (5.6.3.0). Mac OS Big Sur and Windows 10, both systems. Using a render settings node, rendering in MPlay with a USD Render ROP node doesnt change a thing.

Not using the py3 builds.

lightingsolarisusd
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Vinicius Paciello avatar image
Vinicius Paciello answered

Got it. Inside Solaris, Arnold does not compute shaderless geometries with a simple grey surface like in other DCC or even in Houdini but outside Solaris. Cant believe it. Lol.

As I'm working in a rough layout, just added a grey standard surface to all primitives for now. God...

10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Stephen Blair avatar image
Stephen Blair answered

They all work for me.

For Distant, I had to enable Normalize Power

1 comment
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

If I go to obj level, import the usd then render it outside solaris, it works fine, but I cant work inside solaris this way. Any tips? Cant figure this out

0 Likes 0 ·
Vinicius Paciello avatar image
Vinicius Paciello answered

here it goes, folks:

a simples cube + sphere light. in karma works fine.

cant solve this and dont know why. arnold is activated and it just ignores lights. in windows, same behavior. =(

screen-shot-2021-07-29-at-205233.png



1 comment
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

in karma. just to mention that exporting the usd and rendering it in arnold - whether in max, maya or houdini's object level - works fine. its just not working inside solaris

screen-shot-2021-07-29-at-205224.png

0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.