question

Andrew Brewer avatar image
Andrew Brewer asked ·

C4DtoA AOVs with Team Render

New to Arnold but I appear to have my AOV passes and obj mattes all rendering and saving nicely in a layered EXR yet when I'm working locally, yet when I try to use Team Render all I get back is a main beauty pass and an alpha.

Can someone help with what i'm missing here please!

c4dtoaaovsrender farmrender machines
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Peter Horvath avatar image
Peter Horvath answered ·

It should work fine, no extra setup is needed for Team Render. What's your Cinema 4D and C4DtoA version? I'll take a look tomorrow if I can reproduce it.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Andrew Brewer avatar image
Andrew Brewer answered ·

Ah thanks dude. Yeah, i'm using R.19 and Arnold 5. Have been using 'file from render settings (multipass)' and multi layer exrs - tried a different settings and variations but was chasing my tail...

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Peter Horvath avatar image
Peter Horvath answered ·

Wait, the Arnold drivers are not supported in Team Render. You can only use the native (Multi-Pass Image) Save in the render settings.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Andrew Brewer avatar image
Andrew Brewer answered ·

Ah ok. So I can't render AOVs with Team Render? What a shame - i guess production houses just send their scenes to farms then?

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Peter Horvath avatar image
Peter Horvath answered ·

You can render AOVs with Team Render, you just have setup the AOVs for the <display driver> and save a Multi-Layer EXR in the render settings. That should work.

2 comments Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Peter, I am a little bit confused here. We do this all the time - use team render with arnold drivers. Typically we either do not enable save at all in the render settings, or we use the Arnold Dummy, in the case of using Render Queue.

I'm not sure if this applies to distributed still frames, but unless I'm seriously mistaken, Arnold Drivers do seem to work for team rendered sequences. Could you please clarify?

0 Likes 0 · ·

Right, sorry I was not clear. So the Arnold drivers are processed on the client machines. If you specify the path properly (valid on the clients) then they work with sequences. But not with still frames, because they render only a part of the image on each client.

0 Likes 0 · ·
Andrew Brewer avatar image
Andrew Brewer answered ·

Thanks guys, looks like I might have been falling over then with both trying to render one test image and also attempting to use the native render settings. I've had to streamline my output in light of hitting a deadline anyway but I look forward to getting this working soon.

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Akehurstm Akehurstm avatar image
Akehurstm Akehurstm answered ·

Hi @Peter Horvath - I'm having a similar issue to Andrew above:

C4DtoA project - submitted to a 28 node Team Render Server controlled farm with Display Driver and Multiple AOVs within the project.

But the Team Render only produces main beauty and alpha. It appears to ignore all AOV requests.

When the project is run locally it produces all AOVs as expected.

I was hoping that maybe a fix/work around for this issue had been found?

We've only recently updated the Render Farm to support Arnold - but this AOV problem has affected all Arnold projects submitted to it.

Our local machines and the render nodes are running:

C4D R21.115

C4DtoA 2.6.1.5 [a79361bf]

Arnold core 5.4.0.2


Thanks greatly for your time!

(I've attached screen grabs of render setting from one of the projects)

C4DtoA_AOVs.PNGC4DtoA_Output.PNG


c4dtoa-aovs.png (31.6 KiB)
c4dtoa-output.png (28.3 KiB)
Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.