question

zhao peng avatar image
zhao peng asked ·

why my alembic procedural always crash during rendering arnold5.1

my custom alembic procedural can normaly render in arnold5.0,but can't in arnold5.1, i will show this

this node can render, each procedural node can render by itself, that means if the ass only have one procedural is ok

this case is also ok,but when i load two procedural node, it will crash

At the moment, I think that multiple nodes will not work,but

now,I found this problem may be the uv or normal

ERROR | [polymesh] JueLei_A_Render_AR_Shader_1Shape/JueLei_A_04_Model_H_Shader_Ar_Wind/JueLei_A_Render_AR_Shader_1Shape: incorrectly defined normals, missing either nlist or nidxs

but why this node can render by itself ????????

procedurals
rb.png (182.7 KiB)
15260409821.jpg (171.6 KiB)
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Ashley Handscomb Retallack avatar image
Ashley Handscomb Retallack answered ·

Can you try adding

enable_procedural_cache off 

or

parallel_node_init off

in the user options of the render settings?

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

zhao peng avatar image
zhao peng answered ·

abc procedural is my custom node, not mtoa alembic

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

zhao peng avatar image
zhao peng answered ·

but i use 5.1.0.1

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Alexis Prayez avatar image
Alexis Prayez answered ·

Which Mtoa are you using ? Arnold core 5.1 introduced a bug where render might crash when encountering invalid nodes from a procedural (ass, abc, xgen...). This was fixed 5.1.0.1 (mtoa-3.0.0.2).

I know this caused issue on our side where ASS working fine in 5.0 were now crashing with 5.1...

Share
10 |600 characters needed characters left characters exceeded

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 5 attachments (including images) can be used with a maximum of 2.0 MiB each and 9.8 MiB total.

Welcome to the Arnold Answers community.

This is the place for Arnold renderer users everywhere to ask and answer rendering questions, and share knowledge about using Arnold, Arnold plugins, workflows and developing tools with Arnold.

If you are a new user to Arnold Answers, please first check out our FAQ and User Guide for more information.

When posting questions, please be sure to select the appropriate Space for your Arnold plugin and include the plugin version you are using.

Please include images, scene and log files whenever possible as this helps the community answer your questions.

Instructions for generating full verbosity log files are available for MtoA, MaxtoA, C4DtoA, HtoA, KtoA, and Kick.

If you are looking for Arnold Documentation and Support please visit the Arnold Support site.

To try Arnold please visit the Arnold Trial page.

Bottom No panel present for this section.